All systems have been restored to normal functionality.
Posted May 29, 2026 - 11:57 PDT
Update
Microsoft Azure is in the final stages of their recovery process. 10% of agencies are still affected and should see connectivity begin to recover as the remaining systems are restored over the next few hours.
Posted May 29, 2026 - 11:28 PDT
Update
Microsoft Azure is continuing their recovery process. Our monitoring shows that the same 10% of agencies are still impacted, and the remaining 90% are fully functional.
Posted May 29, 2026 - 10:55 PDT
Update
We are still monitoring Microsoft Azure's mitigation updates. 90% of agencies remain unaffected.
Posted May 29, 2026 - 10:25 PDT
Update
Microsoft Azure is still working on mitigating the impact to the remaining services. 90% of agencies remain unaffected at this point.
Posted May 29, 2026 - 10:02 PDT
Update
Metrics remain stable for affected agencies, but the remaining 10% may still experience intermittent connectivity failures.
Posted May 29, 2026 - 09:37 PDT
Update
Metrics have stabilized at a lower error rate for affected agencies, but the remaining 10% may still experience intermittent connectivity failures.
Posted May 29, 2026 - 09:21 PDT
Update
Metrics have significantly improved for the remaining affected agencies, but the remaining 10% may still experience intermittent connectivity failures.
Posted May 29, 2026 - 09:03 PDT
Update
90% of agencies are operational, Microsoft Azure is slowly restoring service to the remaining 10% of affected resources. We have observed improved availability for some of the remaining agencies.
Posted May 29, 2026 - 08:43 PDT
Update
90% of agencies are operational, Microsoft Azure is slowly restoring service to the remaining 10% of affected resources.
Posted May 29, 2026 - 08:22 PDT
Update
Microsoft Azure is still working on mitigating the impact of the outage. Some services have begun to recover. We are monitoring the situation.
Posted May 29, 2026 - 08:07 PDT
Identified
Microsoft Azure has reported an incident affecting connectivity to our cloud services. Requests may fail intermittently. They are working on mitigation, and performance should begin to improve across all services as the incident is resolved.
Posted May 29, 2026 - 05:43 PDT
Investigating
We are aware of a service degradation currently impacting HawkSoft Cloud. We are working to resolve the issue as quickly as possible. Thank you for your patience.
Posted May 29, 2026 - 05:22 PDT
This incident affected: Authentication / Sign-in, Client Services (client, search, tasks, attachments), Accounting, Commissions, Downloads, Partner Integrations, and Reporting.